Jump to content

  •  

Welcome to PC Tech Talk


Sign In  Log in with Facebook

Create Account
Welcome to PC Tech Talk, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of PC Tech Talk by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members.
 
Guest Message by DevFuse

Photo
- - - - -

How do I unblock listening port for Bitcomet


  • This topic is locked This topic is locked
6 replies to this topic

#1 4joey1

4joey1

    Cow-in-development

  • Members
  • 4 posts

Posted 10 August 2008 - 01:39 PM

Hallo!I have been trying to use Bitcomet to download torrents.Unfortunately,the download speeds are extremely slow (about 1-2kbps).

Having looked at various strategies on how to increase the speed,I have stumbled upon the use of port forwarding .My BitComet IP address 41.223.57.33 is blocked as shown by the yellow light and I set my port no as 51000.I need to unblock it.

Unfortunately I have been unable to unblock it.I am using a Huawei e220 hsdpa wireless modem for my internet connection and have tried to configure my BitComet to work with the modem

For instance my IP Configuration (which is obtained automatically)at one connection session is as below

IP Address 172.20.6.71
Subnet Mask 255.255.255.255
Default Gateway 172.20.6.71
DNS Servers 172.30.8.25 and 196.201.231.167

I have tried to set up a static IP address using the IP Configuration above.Unfortunately,whenever I restart my Dial-Up connection it obtains a new IP Configuration automatically thus my static IP settings are erased.

Also when I type my Default Gateway address on the web browser i.e. http:// 172.20.6.71/ , a connection is not established.

How do I solve this problem and please give me further instructions on how to complete my IP forwarding.Thanks in advance.

#2 The UnUsual Suspect

The UnUsual Suspect

    MOOving Right Along....

  • Members
  • 109 posts

Posted 10 August 2008 - 05:37 PM

Hi,

I'm confused about one thing, are you actually on a dial-up connection? or a type of broadband?

If your using a 56kb/s dial-up, then when converted from bits to Bytes, that would be 7kB/s, then when divided between upload/download and overhead, 1-2kB/s is about all you can expect.

As for your listening port. If your modem is also a router, then you can log into it and open your port. Portforward.com has guides for most routers.

If its just a modem, then the router your behind is under the control of your ISP. In that case, your only option if they can't give you an open port is to enable "Nat Traversal" in BitComet. This will allow "some" remote connections. Its not as good as an open port, but better then being blocked.

I believe Nat Traversal was removed in version 103, so revert to a previous version.

#3 kluelos

kluelos

    Pasture Blaster

  • Members
  • 1,715 posts

Posted 10 August 2008 - 05:46 PM

You have a wireless internet connection. Unfortunately, almost all of these are behind firewalls that you do not control.

Your "public" IP address is in the 41.xxx.xxx.xxx block. Your connection is going through a router, which creates a LAN, and your private IP address on that LAN is in the 172.xxx.xxx.xxx block. All of your queries go through the router which substitutes its IP address (the 41.xxx etc address) for yours, sends the queries, collects the replies, and, um, routes them back to your computer.

Almost all wireless connections of whatever sort, include a firewall to block unsolicited incoming connections. For most things this is goodness but it blocks P2P. Usually there's nothing you can do about it except change to a different sort of connection, usually from a different ISP.

Having a firewall isn't inherently part of wireless connections -- it's just usually the case that the two go together.

Most ISP's will not configure their routers to accommodate you, so you will probably have to just live with this.

#4 kluelos

kluelos

    Pasture Blaster

  • Members
  • 1,715 posts

Posted 10 August 2008 - 05:53 PM

Hi,

I'm confused about one thing, are you actually on a dial-up connection? or a type of broadband?


That's basically a cellular modem. So both, sorta.

#5 The UnUsual Suspect

The UnUsual Suspect

    MOOving Right Along....

  • Members
  • 109 posts

Posted 11 August 2008 - 09:46 PM

Ok, I understand now.

Your best bet is a version of BitComet that supports Nat Traversal. I think 1.02 has it, but 1.03 does not. They removed it to make tcp connections more efficient. I imagine they are trying to troubleshoot the problem Nat Traversal was causing, and will reintroduce it in future versions, so check the release notes as new versions are released.

#6 vale95ntino

vale95ntino

    Cow-in-development

  • Members
  • 4 posts

Posted 10 August 2009 - 09:12 AM

hello
i have both green lights in bitcomet
but i PFPortCheck says listening port not open
and i only have local peers

WHAT DO I DO??????????

#7 cassie

cassie

    Administrator

  • Administrators
  • 988 posts

Posted 10 August 2009 - 05:00 PM

vale95ntino,

1) Do NOT make duplicate posts in multiple forums, once is enough.

2) It's a much better idea to start your own tthread in the appropriate forum, rather to jump in the middle of someone else's (sometimes, very old) topic.

3) Follow the Rules of the Forums (you promised to do so, when you first registered).

4) Start by reading here.


*this topic is closed*




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users